Jump to content

Noisy Eheim 2215


wes1000
 Share

Recommended Posts

Hey, I have had a Eheim 2215 for about 2.5 years now and i love it. I have never had a problem with it until now. It is starting to make a small knocking noise. After reading around here and other forums I believe that it could be the propellor that is starting to wear out.

Am i on the right track or is it something totally different?????

Link to comment
Share on other sites

store i work at stocks eheim, if any happen to come back with similar problems thats usually one of the main causes, has your flow rate decreased at all?

Other thing to check for is that theres no gravel etc in your pipes or snails aswell

But first thing id check is the impellor shaft, just be careful just incase its not broken

If that fails then check to make sure the impellor assembly is stil in tact

Link to comment
Share on other sites

In two and a half years have you cleaned the impeller and its parts and housing. If not do so and this will most likely fix the issue. Be carefull of the shaft as it's ceramic (better wearing) and easy to break. Treat it like glass. Oh...and don't loose the rubber end stops that hold the shaft in place, they sometimes fall out when cleaning.

Edited by CThompson
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...