Jump to content

Aqua one cf1200 leaking?


howard
 Share

Recommended Posts

Hi guys, im always buying these filters because they do a good job, but i get an odd 1 or 2 which work fine then after a clean out , i put it back together and plug in and come back the next day with a puddle around the canister, i thought these things were securely shut, i dont know wats the problem :dntknw:

has this happened to anyone :confused:

Link to comment
Share on other sites

Need more info mate

leaking from taps ?

round the rubber seal ?

thats the older model did you get the same with newer ones

Aquis 1200

BFJ

That's my problem i don't know from where it seems like it's coming from underneath , and between the bcket and the motor , is that possible

Link to comment
Share on other sites

Need more info mate

leaking from taps ?

round the rubber seal ?

thats the older model did you get the same with newer ones

Aquis 1200

BFJ

That's my problem i don't know from where it seems like it's coming from underneath , and between the bcket and the motor , is that possible

I've had similar problems once, it tends to be the o-ring that sits between the motor head and the canister, over time the o ring hardens into a position, then once you open it and break it's seal it tends not to go back in to it's original spot, thus the small leak. Just a matter of replacing the main rubber o ring. Either that or it could be a small o ring in the taps. Also make sure the grey hose fixings that screw the tubing into the canister aren't cracked and can be tightened.

Link to comment
Share on other sites

Not that it's much help but I had exactly the same filter and that exact problem.

Mine leaked between the canister and head, which was most likely the main seal.

I was lucky to have a spare and have been using it until now, but now that seal is going too so I'm in need of a new seal.

Let me know if you find a place that sells the seals and I'll do the same. Cheers.

Link to comment
Share on other sites

Not that it's much help but I had exactly the same filter and that exact problem.

Mine leaked between the canister and head, which was most likely the main seal.

I was lucky to have a spare and have been using it until now, but now that seal is going too so I'm in need of a new seal.

Let me know if you find a place that sells the seals and I'll do the same. Cheers.

Thanks so much to the both of you , I guess I'm on the lookout now for one now ,

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...